Форум 3DNews
Вернуться   Форум 3DNews > Софт > Финансовые и бухгалтерские программы

Ответ Создать новую тему
Опции темы Опции просмотра
Непрочитано 28.05.2004, 18:13   [включить плавающее окно]   #1
ReaderMan
Мужской Опытный
Автор темы
 
Аватар для ReaderMan
 
Регистрация: 17.06.2003
Адрес: Москва
Question Как поменять ставку НДС ?

Сам я, 1С знаю никак (почти). Есть надобность поменять ставку НДС с 20 на 18 процентов. (1С торговля 7.7 43 )
В констанатах такого параметра нету. Полез в яндекс,там много разного пишут.Начиная со смены версии,и вплоть до замены ставки в исходниках. Может кто знает как это попроще сделать? Спасибо.
__________________
Голова всё может.
ReaderMan вне форума  
Конфигурация ПК
Ответить с цитированием
Непрочитано 29.05.2004, 16:59   [включить плавающее окно]   #2
Toxas
Мужской Бывалый
 
Аватар для Toxas
 
Регистрация: 05.01.2004
Адрес: Петрозаводск
Справочники -> Налоги -> Ставки НДС.... и там либо меняешь, либо создаёшь ещё одну ставку...
__________________
вот я пью, пью... а мне всё хуже и хуже...
Toxas вне форума  
Ответить с цитированием
Непрочитано 30.05.2004, 23:10   [включить плавающее окно]   #3
J. Corvin
Мужской Заслуженный
 
Аватар для J. Corvin
 
Регистрация: 27.02.2003
Адрес: Мурманск
Цитата
вплоть до замены ставки в исходниках
Именно так... Если быть точным то это прописывается в глобальном модуле...

Цитата
создаёшь ещё одну ставку
Ага... Создай... и потом перещитай документ с этой ставкой вручную, выскажешь про програмистов из 1С много нового.
__________________
it's can't rain all the time
J. Corvin вне форума  
Конфигурация ПК
Ответить с цитированием
Непрочитано 26.06.2004, 03:03   [включить плавающее окно]   #4
Serg_xx
Новенький
 
Регистрация: 07.04.2004
Адрес: Вологда
Все примитивно просто.
1. Лезешь в конфигуратор и ставишь в "перечисление->значенияНДС" новую ставку НДС.
2. Лезешь в глобальный модуль и находишь процедуры глПроцентНДС() или процентНДС() и дописываешь соответствующие строки...
3. Создаешь отчет, который меняет ставку НДС во всех товарах на 01.01.2004 на НоваяСтавкаНДС. Соответствующее значение ставки прописываешь в константы (или в настройки пользователей).
ВСЕ...
Serg_xx вне форума  
Ответить с цитированием
Непрочитано 09.07.2004, 00:18   [включить плавающее окно]   #5
Taxa
Новенький
 
Регистрация: 03.08.2003
Адрес: г. Томск
Это расшифровка предыдущего совета с личными дополнениями. С языком, как Вы говорите, у вас проблемы, поэтому...
Создайте внешний отчет
В Модуле Процедура Сформировать должна получиться такой:
Процедура Сформировать()
Если ВыбНДСНовый.Выбран()=0 Тогда
Предупреждение("Выберете ставку НДС!");
Возврат;
КонецЕсли;
СпрТов=СоздатьОбъект("Справочник.Номенклатура");
i=0;
СпрТов.ВыбратьЭлементы();
Пока СпрТов.ПолучитьЭлемент()>0 Цикл
i=i+1;
Если СпрТов.СтавкаНДС.Получить(ДатаНДС)=ВыбНДС Тогда
СпрТов.СтавкаНДС.Установить(ДатаНДС,ВыбНДСНовый);
Сообщить(""+СпрТов.Наименование+" - ");
Иначе
Продолжить;
КонецЕсли;
СпрТов.Записать();
Состояние("Обработано: "+i+" строк.");
КонецЦикла;
КонецПроцедуры

В диалоге обработки надо добавить три поля:
ДатаНДС - тип "Дата" (дата перехода на новый НДС)
ВыбНДС, ВыбНДСНовый - тип "Справочник.СтавкиНДС" или "Перечисление.ЗначениеНДС", точнее там где эти самые ставки хранятся (поля соответственно для замены старого значения НДС на новое)
Новое значение НДС создайте заранее.

Совет: если Вы сейчас только ставки стали менять, то конфигурация у Вас старовата и в ней наверняка есть глюки. Самый распространенный, когда новая ставка 18% = 21,..% Если так, то в конфигурации поищите проверки (СтНДС = 20)ИЛИ , ну и добавте СтНДС = 18. Искать лучше "= 20"(с пробелом!). Должно найтись в глобальном модуле и в Счет-фактуре.
Не так просто и наглядно, если значения НДС хранятся в перечислении ("совсем старая конфа"), там тогда, скорее всего, надо искать "ОсновнаяСтавкаНДС"

Главное в нашем вопросе: вовремя сделать копию.
Taxa вне форума  
Ответить с цитированием
Ответ Создать новую тему

Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Текущее время: 15:01. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd. Перевод: zCarot
Copyright © 2000-2017 3DNews. All Rights Reserved.
Администрация 3DNews требует соблюдения на форуме правил и законов РФ
Серверы размещены в Hostkey