Форум 3DNews
Вернуться   Форум 3DNews > Софт > Операционные системы Microsoft Windows

Ответ Создать новую тему
Опции темы Опции просмотра
Непрочитано 24.12.2008, 13:29   [включить плавающее окно]   #1
Yura12
Мужской Начинающий
Автор темы
 
Регистрация: 09.01.2007
Адрес: Петрозаводск
Microsoft .NET Framework 1.0 - нужен и актуален ли ещё?

Как известно, Microsoft .NET Framework версий 1.1, 2.0, 3.0, и 3.5 - это всё 4 разных продукта, которые устанавливаются в разные папки (и также есть программы, которые написаны именно под определённую версию .NET Framework):
C:\WINDOWS\Microsoft.NET\Framework\ ...
v1.1.4322
v2.0.50727
v3.0
v3.5
и там есть ещё почти пустая папка v1.0.3705

В общем вопрос, а нужен, актуален ли ещё Microsoft .NET Framework версии 1.0 ?

Есть страница для загрузки версии 1.0 - http://www.microsoft.com/downloads/d...displaylang=en

Однако Microsoft Update не предлагает его в качестве рекомендуемого.

В общем как Вы думаете, а нужен ли он?
Yura12 вне форума  
Ответить с цитированием
Непрочитано 24.12.2008, 14:11   [включить плавающее окно]   #2
Randwer
Мужской Опытный
 
Аватар для Randwer
 
Регистрация: 03.07.2007
Адрес: Кьюнглунг
Если не юзаешь приложения,базирующиеся именно на этой версии,то не нужен.
__________________
Ин найнтин найнти-найн ...
Мне весело в бою.(©)
Randwer вне форума  
Ответить с цитированием
Непрочитано 24.12.2008, 17:16   [включить плавающее окно]   #3
Yura12
Мужской Начинающий
Автор темы
 
Регистрация: 09.01.2007
Адрес: Петрозаводск
Спасибо. Понятно.

А русский языковой пакет для него есть?
Yura12 вне форума  
Ответить с цитированием
Непрочитано 24.12.2008, 18:51   [включить плавающее окно]   #4
Randwer
Мужской Опытный
 
Аватар для Randwer
 
Регистрация: 03.07.2007
Адрес: Кьюнглунг
Судя по твоей ссылке на майкрософт - нет.
__________________
Ин найнтин найнти-найн ...
Мне весело в бою.(©)
Randwer вне форума  
Ответить с цитированием
Непрочитано 25.12.2008, 00:39   [включить плавающее окно]   #5
FooBar
Заслуженный
 
Регистрация: 28.03.2004
На самом деле не совсем так: 3.0 это надстройка над 2.0 и 3.5 надстройка над 3.0. Папки у них конечно разные но рантайм один.

Ни 1.1 ни тем более 1.0 не нужны. Даже если приложение сделано для них они будут работать на 2.0 (3.0/3.5). Есть редкие случаи несовметстимости, тогда придется поставить 1.1.
FooBar вне форума  
Ответить с цитированием
Непрочитано 25.12.2008, 10:53   [включить плавающее окно]   #6
Yura12
Мужской Начинающий
Автор темы
 
Регистрация: 09.01.2007
Адрес: Петрозаводск
Понятно. Спасибо за информацию.

А насчёт русского языка - ситуация вообще непонятная. Я разобрался более детально.

Дистрибутивный пакет - есть только на английском языке!

Но вот Service Pack 3 - NDP1.0sp3-KB867461-X86-Rus.exe , потом обновление 2007 года NDP1.0sp3-KB928367-X86-Rus.exe и мая 2008 года NDP1.0sp3-KB947739-X86-Rus.exe - они есть как на русском, так и на английском языках.

Причём русскоязычные обновления не применяются к англоязычной версии. Тогда зачем вообще русскоязычные обновления, когда изначально самого пакета 1.0 русскоязычного нет !!!
Yura12 вне форума  
Ответить с цитированием
Непрочитано 25.12.2008, 23:01   [включить плавающее окно]   #7
il72
Мужской Умудрённый
 
Аватар для il72
 
Регистрация: 10.11.2004
Адрес: Пермская обл.
Yura12 как нет???
вы че гоните? 5 минут поиска на сайте микробов - http://www.microsoft.com/downloads/d...C-83E78D4ABC5B

это сп3 но можно и первый найти кому надо...у меня на компе все есть.

http://www.microsoft.com/downloads/d...7-034d1e7cf3a3

Последний раз редактировалось il72; 25.12.2008 в 23:03.
il72 вне форума  
Конфигурация ПК
Ответить с цитированием
Непрочитано 26.12.2008, 03:01   [включить плавающее окно]   #8
FooBar
Заслуженный
 
Регистрация: 28.03.2004
А зачем тебе язык для рунтайма? Там кроме сетапа и exception messages (которые только для программеров предназначены) русифицировать нечего.
FooBar вне форума  
Ответить с цитированием
Непрочитано 26.12.2008, 10:53   [включить плавающее окно]   #9
Yura12
Мужской Начинающий
Автор темы
 
Регистрация: 09.01.2007
Адрес: Петрозаводск
Цитата (il72) »
Yura12 как нет???
вы че гоните? 5 минут поиска на сайте микробов - http://www.microsoft.com/downloads/d...C-83E78D4ABC5B

это сп3 но можно и первый найти кому надо...у меня на компе все есть.

http://www.microsoft.com/downloads/d...7-034d1e7cf3a3
Первая ссылка - на Service Pack 3, а вторая - на русскую версию 1.1 (а надо 1.0).
Yura12 вне форума  
Ответить с цитированием
Непрочитано 27.12.2008, 00:07   [включить плавающее окно]   #10
il72
Мужской Умудрённый
 
Аватар для il72
 
Регистрация: 10.11.2004
Адрес: Пермская обл.
1.0 шел с аглицкой виндой в 2001 году...для остальных сделали 1.1 а та папка...хз
Цитата
Чтобы определить номер основной версии пакета .NET Framework, установленного на компьютере, используйте следующий метод.
Если папка %windir%\Microsoft.net\Framework\v1.0.3705 содержит более четырех файлов, значит, установлен пакет .NET Framework 1.0. Если данная папка содержит только приведенные ниже файлы, значит, пакет .NET Framework 1.0 не установлен.
Installutil.exe.config
Mscormmc.cfg
Mscormmc.dll
Regsvcs.exe.rtm.config
Если существует папка %windir%\Microsoft.net\Framework\v1.1.4322, значит, установлен пакет .NET Framework 1.1.
il72 вне форума  
Конфигурация ПК
Ответить с цитированием
Непрочитано 04.06.2010, 21:03   [включить плавающее окно]   #11
Yura12
Мужской Начинающий
Автор темы
 
Регистрация: 09.01.2007
Адрес: Петрозаводск
Немного не в тему (но не хочу плодить другие темы).

А представляете, в Windows 7 не ставится ни 1.0 ни 1.1 версия .NET Framework

Ну под 1.0 ладно, программ практически нет (или большая редкость).

А вот под 1.1 - ещё много. А как быть теперь если их надо запускать под Windows 7, а .NET Framework на Windows 7 не ставится
Yura12 вне форума  
Ответить с цитированием
Непрочитано 04.06.2010, 21:57   [включить плавающее окно]   #12
Smirnoff
Мужской Модератор
 
Аватар для Smirnoff
 
Регистрация: 30.12.2004
Адрес: Новосибирск
Цитата (Yura12) »
под 1.1 - ещё много. А как быть теперь если их надо запускать под Windows 7, а .NET Framework на Windows 7 не ставится
Вероятно, нужно перейти на свежие версии этих программ?..
__________________
С уважением,
Олег Р. Смирнов
Smirnoff вне форума  
Конфигурация ПК
Ответить с цитированием
Непрочитано 05.06.2010, 12:40   [включить плавающее окно]   #13
Fakir
Мужской Модератор
 
Аватар для Fakir
 
Регистрация: 26.04.2004
Адрес: Тольятти
Yura12, не понял, в чем проблема?
__________________
Решил проблему, сообщи мне, как…
Fakir вне форума  
Конфигурация ПК
Ответить с цитированием
Непрочитано 05.06.2010, 15:47   [включить плавающее окно]   #14
Smirnoff
Мужской Модератор
 
Аватар для Smirnoff
 
Регистрация: 30.12.2004
Адрес: Новосибирск
Цитата (Fakir) »
в чем проблема?
Вероятно, у него имеется некоторое количество программ, использующих .NET Framework 1.1, и
Цитата (Yura12) »
их надо запускать под Windows 7, а .NET Framework на Windows 7 не ставится
__________________
С уважением,
Олег Р. Смирнов
Smirnoff вне форума  
Конфигурация ПК
Ответить с цитированием
Ответ Создать новую тему

Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Текущее время: 17:25. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd. Перевод: zCarot
Copyright © 2000-2017 3DNews. All Rights Reserved.
Администрация 3DNews требует соблюдения на форуме правил и законов РФ
Серверы размещены в Hostkey